What’s Vulnerable › Vulnerabilities
CVE-2024-37081
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-556
Description
The vCenter Server contains multiple local privilege escalation vulnerabilities due to misconfiguration of sudo. An authenticated local user with non-administrative privileges may exploit these issues to elevate privileges to root on vCenter Server Appliance.
Affected products
- VMware Cloud Foundation: from 4.0 before 5.2 — fixed in 5.2
- VMware vCenter Server: 8.0, 8.0-a, 8.0-b, 8.0-c, 8.0-update1, 8.0-update1a (+39)
- VMware Cloud Foundation: from 4.0 before 6.0 — fixed in 6.0
- VMware vCenter Server: from 8.0 before 8.0u2d — fixed in 8.0u2d
- VMware Cloud Foundation: 5.x, 4.x
- VMware vCenter Server: from 8.0 before 8.0 U2d; from 7.0 before 7.0 U3r — fixed in 8.0 U2d, 7.0 U3r
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.2; VMware Cloud Foundation 6.0; VMware vCenter Server 8.0u2d; VMware vCenter Server 8.0 U2d, 7.0 U3r. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
Get alerted when CVE-2024-37081 or the next vulnerability affects your stack