What’s Vulnerable › Vulnerabilities
CVE-2024-37082
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-290
Description
When deploying Cloud Foundry together with the haproxy-boshrelease and using a non default configuration, it might be possible to craft HTTP requests that bypass mTLS authentication to Cloud Foundry applications. You are affected if you have route-services enabled in routing-release and have configured the haproxy-boshrelease property “ha_proxy.forwarded_client_cert” to “forward_only_if_route_service”.
Affected products
- Cloud Foundry haproxy-boshrelease: before 0.299.0 — fixed in 0.299.0
How to fix
Upgrade to a fixed version: Cloud Foundry haproxy-boshrelease 0.299.0. Check the vendor advisory for mitigations.
References
- https://www.cloudfoundry.org/blog/cve-2024-37082-mtls-bypass/
- https://www.cloudfoundry.org/blog/cve-2024-37082-mtls-bypass/
Get alerted when CVE-2024-37082 or the next vulnerability affects your stack