What’s Vulnerable › Vulnerabilities
CVE-2024-37086
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-125
Description
VMware ESXi contains an out-of-bounds read vulnerability. A malicious actor with local administrative privileges on a virtual machine with an existing snapshot may trigger an out-of-bounds read leading to a denial-of-service condition of the host.
Affected products
- VMware Cloud Foundation: from 4.0 before 5.2 — fixed in 5.2
- VMware ESXi: 7.0-beta, 7.0-update_1, 7.0-update_1a, 7.0-update_1b, 7.0-update_1c, 7.0-update_1d (+33); 7.0, 8.0
- ESXi: from 8.0 before ESXi80U3-24022510; from 7.0 before ESXi70U3sq-23794019 — fixed in ESXi80U3-24022510, ESXi70U3sq-23794019
- VMware Cloud Foundation: 5.x, 4.x
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.2; ESXi ESXi80U3-24022510, ESXi70U3sq-23794019. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24505
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24505
Get alerted when CVE-2024-37086 or the next vulnerability affects your stack