What’s Vulnerable › Vulnerabilities
CVE-2024-3711: Brizy – Page Builder <= 2.4.43 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The Brizy – Page Builder plugin for WordPress is vulnerable to unauthorized plugin setting update due to a missing capability check on the functions action_request_disable, action_change_template, and action_request_enable in all versions up to, and including, 2.4.43. This makes it possible for authenticated attackers, with contributor access or above, to enable/disable the Brizy editor and modify the template used.
Affected products
- themefusecom Brizy – Page Builder: before 2.4.44 — fixed in 2.4.44
How to fix
Upgrade to a fixed version: themefusecom Brizy – Page Builder 2.4.44. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/brizy/trunk/admin/main.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3086506%40brizy%2Ftrunk&old=3058896%40brizy%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7092ce4a-bad9-4426-b94e-d9d688344272?source=cve
- https://plugins.trac.wordpress.org/browser/brizy/trunk/admin/main.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3086506%40brizy%2Ftrunk&old=3058896%40brizy%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7092ce4a-bad9-4426-b94e-d9d688344272?source=cve
Get alerted when CVE-2024-3711 or the next vulnerability affects your stack