What’s Vulnerable › Vulnerabilities
CVE-2024-37142
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-31 · updated 2026-06-17
- Weakness: CWE-427
Description
Dell Peripheral Manager, versions prior to 1.7.6, contain an uncontrolled search path element vulnerability. An attacker could potentially exploit this vulnerability through preloading malicious DLL or symbolic link exploitation, leading to arbitrary code execution and escalation of privilege
Affected products
- Dell Peripheral Manager: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: Dell Peripheral Manager 1.7.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37142 or the next vulnerability affects your stack