What’s Vulnerable › Vulnerabilities
CVE-2024-37149: GLPI allows remote code execution through the plugin loader
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-73
Description
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. An authenticated technician user can upload a malicious PHP script and hijack the plugin loader to execute this malicious script. Upgrade to 10.0.16.
Affected products
- glpi-project glpi: from 0.85 before 10.0.16 — fixed in 10.0.16
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.16. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/security/advisories/GHSA-cwvp-j887-m4xh
- https://github.com/glpi-project/glpi/security/advisories/GHSA-cwvp-j887-m4xh
Get alerted when CVE-2024-37149 or the next vulnerability affects your stack