What’s Vulnerable › Vulnerabilities
CVE-2024-37157: Discourse vulnerable to Server-Side Request Forgery via FastImage
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-918
Description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches, a malicious actor could get the FastImage library to redirect requests to an internal Discourse IP. This issue is patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches. No known workarounds are available.
Affected products
- discourse: before 3.2.3; before 3.3.0; 3.3.0-beta1, 3.3.0-beta2, 3.3.0-beta3 — fixed in 3.2.3, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.3, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/5b8cf11b69e05d5c058c1148ec69ec309491fa6e
- https://github.com/discourse/discourse/commit/67e78086035cec494b15ce79342a0cb9052c2d95
- https://github.com/discourse/discourse/security/advisories/GHSA-46pq-7958-fc68
- https://github.com/discourse/discourse/commit/5b8cf11b69e05d5c058c1148ec69ec309491fa6e
- https://github.com/discourse/discourse/commit/67e78086035cec494b15ce79342a0cb9052c2d95
- https://github.com/discourse/discourse/security/advisories/GHSA-46pq-7958-fc68
Get alerted when CVE-2024-37157 or the next vulnerability affects your stack