What’s Vulnerable › Vulnerabilities
CVE-2024-37162: zsa Generates Error Messages Containing Sensitive Information
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-209
Description
zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.
Affected products
- IdoPesok zsa: before 0.3.3 — fixed in 0.3.3
How to fix
Upgrade to a fixed version: IdoPesok zsa 0.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/IdoPesok/zsa/commit/86b86b282bde6780963f62406cc8bc65f2c86f3a
- https://github.com/IdoPesok/zsa/security/advisories/GHSA-wjmj-h3xc-hxp8
- https://github.com/IdoPesok/zsa/commit/86b86b282bde6780963f62406cc8bc65f2c86f3a
- https://github.com/IdoPesok/zsa/security/advisories/GHSA-wjmj-h3xc-hxp8
Get alerted when CVE-2024-37162 or the next vulnerability affects your stack