What’s Vulnerable › Vulnerabilities
CVE-2024-37165: Discourse has an XSS via Onebox system
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source discussion platform. Prior to 3.2.3 and 3.3.0.beta3, improperly sanitized Onebox data could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. This vulnerability is fixed in 3.2.3 and 3.3.0.beta3.
Affected products
- discourse: before 3.2.3; 3.3.0-beta1, 3.3.0-beta2 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: discourse 3.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2
- https://github.com/discourse/discourse/security/advisories/GHSA-cx83-5p6x-9qh9
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2
- https://github.com/discourse/discourse/security/advisories/GHSA-cx83-5p6x-9qh9
Get alerted when CVE-2024-37165 or the next vulnerability affects your stack