What’s Vulnerable › Vulnerabilities
CVE-2024-37166: ghtml Cross-Site Scripting (XSS) vulnerability
- Severity: high (CVSS 8.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-10 · updated 2026-06-17
- Weakness: CWE-79
Description
ghtml is software that uses tagged templates for template engine functionality. It is possible to introduce user-controlled JavaScript code and trigger a Cross-Site Scripting (XSS) vulnerability in some cases. Version 2.0.0 introduces changes to mitigate this issue. Version 2.0.0 contains updated documentation to clarify that while ghtml escapes characters with special meaning in HTML, it does not provide comprehensive protection against all types of XSS attacks in every scenario. This aligns with the approach taken by other template engines. Developers should be cautious and take additional measures to sanitize user input and prevent potential vulnerabilities. Additionally, the backtick character (`) is now also escaped to prevent the creation of strings in most cases where a malicious actor somehow gains the ability to write JavaScript. This does not provide comprehensive protection either.
Affected products
- gurgunday ghtml: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: gurgunday ghtml 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/gurgunday/ghtml/commit/df1ea50fe8968a766fd2b9379a8f9806375227f8
- https://github.com/gurgunday/ghtml/security/advisories/GHSA-vvhj-v88f-5gxr
- https://github.com/gurgunday/ghtml/commit/df1ea50fe8968a766fd2b9379a8f9806375227f8
- https://github.com/gurgunday/ghtml/security/advisories/GHSA-vvhj-v88f-5gxr
Get alerted when CVE-2024-37166 or the next vulnerability affects your stack