What’s Vulnerable › Vulnerabilities
CVE-2024-37231: WordPress Salon booking system plugin <= 9.9 - Arbitrary File Deletion vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Salon Booking System Salon booking system allows File Manipulation.This issue affects Salon booking system: from n/a through 9.9.
Affected products
- Salon booking system: before 10.0 — fixed in 10.0
How to fix
Upgrade to a fixed version: Salon booking system 10.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/salon-booking-system/wordpress-salon-booking-system-plugin-9-9-arbitrary-file-deletion-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/salon-booking-system/wordpress-salon-booking-system-plugin-9-9-arbitrary-file-deletion-vulnerability?_s_id=cve
Get alerted when CVE-2024-37231 or the next vulnerability affects your stack