What’s Vulnerable › Vulnerabilities
CVE-2024-37258: WordPress Social Rocket plugin <= 1.3.3 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Social Rocket allows Reflected XSS.This issue affects Social Rocket: from n/a through 1.3.3.
Affected products
- socialrocket Social Rocket – Social Sharing Plugin: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: socialrocket Social Rocket – Social Sharing Plugin 1.3.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/social-rocket/wordpress-social-rocket-plugin-1-3-3-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/social-rocket/wordpress-social-rocket-plugin-1-3-3-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37258 or the next vulnerability affects your stack