What’s Vulnerable › Vulnerabilities
CVE-2024-37259: WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended.This issue affects The Ultimate WordPress Toolkit – WP Extended: from n/a through <= 2.4.7.
Affected products
- wpextended The Ultimate WordPress Toolkit – WP Extended: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: wpextended The Ultimate WordPress Toolkit – WP Extended 3.0.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/wpextended/vulnerability/wordpress-wp-extended-plugin-2-4-7-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wpextended/wordpress-wp-extended-plugin-2-4-7-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37259 or the next vulnerability affects your stack