What’s Vulnerable › Vulnerabilities
CVE-2024-37271: WordPress Print My Blog plugin <= 3.27.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Nelson Print My Blog print-my-blog.This issue affects Print My Blog: from n/a through <= 3.27.0.
Affected products
- Michael Nelson Print My Blog: before 3.27.1 — fixed in 3.27.1
How to fix
Upgrade to a fixed version: Michael Nelson Print My Blog 3.27.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/print-my-blog/vulnerability/wordpress-print-my-blog-plugin-3-27-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/print-my-blog/wordpress-print-my-blog-plugin-3-27-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37271 or the next vulnerability affects your stack