What’s Vulnerable › Vulnerabilities
CVE-2024-37277: WordPress Paid Memberships Pro plugin <= 3.0.4 - Insecure Direct Object References (IDOR) vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-01 · updated 2026-06-17
- Weakness: CWE-639
Description
Authorization Bypass Through User-Controlled Key vulnerability in Paid Memberships Pro allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Paid Memberships Pro: from n/a through 3.0.4.
Affected products
- Paid Memberships Pro: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: Paid Memberships Pro 3.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37277 or the next vulnerability affects your stack