What’s Vulnerable › Vulnerabilities
CVE-2024-37280: Elasticsearch StackOverflow vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-122
Description
A flaw was discovered in Elasticsearch, affecting document ingestion when an index template contains a dynamic field mapping of “passthrough” type. Under certain circumstances, ingesting documents in this index would cause a StackOverflow exception to be thrown and ultimately lead to a Denial of Service. Note that passthrough fields is an experimental feature.
Affected products
- Elasticsearch: from 8.13.1 before 8.14.0 — fixed in 8.14.0
How to fix
Upgrade to a fixed version: Elasticsearch 8.14.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elasticsearch-8-14-0-security-update-esa-2024-14/361007
- https://discuss.elastic.co/t/elasticsearch-8-14-0-security-update-esa-2024-14/361007
- https://security.netapp.com/advisory/ntap-20240816-0003/
Get alerted when CVE-2024-37280 or the next vulnerability affects your stack