What’s Vulnerable › Vulnerabilities
CVE-2024-37281: Kibana Denial of Service issue
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in Kibana where a user with Viewer role could cause a Kibana instance to crash by sending a large number of maliciously crafted requests to a specific endpoint.
Affected products
- Kibana: from 7.0.0 before 7.17.23; from 8.0.0 before 8.14.0 — fixed in 7.17.23, 8.14.0
How to fix
Upgrade to a fixed version: Kibana 7.17.23, 8.14.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/kibana-7-17-23-8-14-0-security-update-esa-2024-16/364094
- https://discuss.elastic.co/t/kibana-7-17-23-8-14-0-security-update-esa-2024-16/364094
Get alerted when CVE-2024-37281 or the next vulnerability affects your stack