What’s Vulnerable › Vulnerabilities
CVE-2024-37282
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-28 · updated 2026-06-17
- Weakness: CWE-285
Description
It was identified that under certain specific preconditions, an API key that was originally created with a specific privileges could be subsequently used to create new API keys that have elevated privileges.
Affected products
- Elastic Cloud Enterprise: from 3.0.0 before 3.7.2 — fixed in 3.7.2
How to fix
Upgrade to a fixed version: Elastic Cloud Enterprise 3.7.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-cloud-enterprise-3-7-2-security-update-esa-2024-18/362181
- https://discuss.elastic.co/t/elastic-cloud-enterprise-3-7-2-security-update-esa-2024-18/362181
Get alerted when CVE-2024-37282 or the next vulnerability affects your stack