What’s Vulnerable › Vulnerabilities
CVE-2024-3729: Frontend Admin by DynamiApps <= 3.19.4 - Improper Missing Encryption Exception Handling to Form Manipulation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-636
Description
The Frontend Admin by DynamiApps plugin for WordPress is vulnerable to improper missing encryption exception handling on the 'fea_encrypt' function in all versions up to, and including, 3.19.4. This makes it possible for unauthenticated attackers to manipulate the user processing forms, which can be used to add and edit administrator user for privilege escalation, or to automatically log in users for authentication bypass, or manipulate the post processing form that can be used to inject arbitrary web scripts. This can only be exploited if the 'openssl' php extension is not loaded on the server.
Affected products
- shabti Frontend Admin by DynamiApps: before 3.19.5 — fixed in 3.19.5
How to fix
Upgrade to a fixed version: shabti Frontend Admin by DynamiApps 3.19.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/acf-frontend-form-element/tags/3.18.15/main/helpers.php#L617
- https://plugins.trac.wordpress.org/changeset/3073379/acf-frontend-form-element#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a2d22c5d-5ef5-4920-a1b5-e8284394c7e8?source=cve
- https://plugins.trac.wordpress.org/browser/acf-frontend-form-element/tags/3.18.15/main/helpers.php#L617
- https://plugins.trac.wordpress.org/changeset/3073379/acf-frontend-form-element#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a2d22c5d-5ef5-4920-a1b5-e8284394c7e8?source=cve
Get alerted when CVE-2024-3729 or the next vulnerability affects your stack