What’s Vulnerable › Vulnerabilities
CVE-2024-37297: WooCommerce has a Cross-Site Scripting Vulnerability in checkout & registration forms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-79
Description
WooCommerce is an open-source e-commerce platform built on WordPress. A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the `Sourcebuster.js` library and then inserted without proper sanitization to the classic checkout and registration forms. Versions 8.8.5 and 8.9.3 contain a patch for the issue. As a workaround, one may disable the Order Attribution feature.
Affected products
- Automattic WooCommerce: from 8.8 before 8.8.5; from 8.9.0 before 8.9.3 — fixed in 8.8.5, 8.9.3
How to fix
Upgrade to a fixed version: Automattic WooCommerce 8.8.5, 8.9.3. Check the vendor advisory for mitigations.
References
- https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0
- https://github.com/woocommerce/woocommerce/commit/0e9888305d0cb9557e58f558526ab11cb3bcc4b4
- https://github.com/woocommerce/woocommerce/commit/915e32a42762916b745a7e663c8b69a698da8b67
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-cv23-q6gh-xfrf
- https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0
- https://github.com/woocommerce/woocommerce/commit/0e9888305d0cb9557e58f558526ab11cb3bcc4b4
- https://github.com/woocommerce/woocommerce/commit/915e32a42762916b745a7e663c8b69a698da8b67
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-cv23-q6gh-xfrf
Get alerted when CVE-2024-37297 or the next vulnerability affects your stack