What’s Vulnerable › Vulnerabilities
CVE-2024-37299: Discourse vulnerable to DoS via Tag Group
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, crafting requests to submit very long tag group names can reduce the availability of a Discourse instance. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
Affected products
- discourse: before 3.2.5; 3.3.0-beta1, 3.3.0-beta2, 3.3.0-beta3, 3.3.0-beta4 — fixed in 3.2.5
How to fix
Upgrade to a fixed version: discourse 3.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e
- https://github.com/discourse/discourse/security/advisories/GHSA-4j6h-9pjp-5476
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e
- https://github.com/discourse/discourse/security/advisories/GHSA-4j6h-9pjp-5476
Get alerted when CVE-2024-37299 or the next vulnerability affects your stack