What’s Vulnerable › Vulnerabilities
CVE-2024-37305: Buffer overflow in deserialization in oqs-provider
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-17 · updated 2026-06-17
- Weakness: CWE-120
Description
oqs-provider is a provider for the OpenSSL 3 cryptography library that adds support for post-quantum cryptography in TLS, X.509, and S/MIME using post-quantum algorithms from liboqs. Flaws have been identified in the way oqs-provider handles lengths decoded with DECODE_UINT32 at the start of serialized hybrid (traditional + post-quantum) keys and signatures. Unchecked length values are later used for memory reads and writes; malformed input can lead to crashes or information leakage. Handling of plain/non-hybrid PQ key operation is not affected. This issue has been patched in in v0.6.1. All users are advised to upgrade. There are no workarounds for this issue.
Affected products
- Open Quantum Safe Oqs Provider: before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: Open Quantum Safe Oqs Provider 0.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/open-quantum-safe/oqs-provider/pull/416
- https://github.com/open-quantum-safe/oqs-provider/security/advisories/GHSA-pqvr-5cr8-v6fx
- https://github.com/open-quantum-safe/oqs-provider/pull/416
- https://github.com/open-quantum-safe/oqs-provider/security/advisories/GHSA-pqvr-5cr8-v6fx
Get alerted when CVE-2024-37305 or the next vulnerability affects your stack