What’s Vulnerable › Vulnerabilities
CVE-2024-37308: WordPress Cooked Plugin - Authenticated (Contributor+) Persistent Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cooked Pro recipe plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the `_recipe_settings[post_title]` parameter in versions up to, and including, 1.7.15.4 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. A patch is available at commit 8cf88f334ccbf11134080bbb655c66f1cfe77026 and will be part of version 1.8.0.
Affected products
- XjSv Cooked: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: XjSv Cooked 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/XjSv/Cooked/commit/8cf88f334ccbf11134080bbb655c66f1cfe77026
- https://github.com/XjSv/Cooked/security/advisories/GHSA-9vfv-c966-jwrv
- https://github.com/XjSv/Cooked/commit/8cf88f334ccbf11134080bbb655c66f1cfe77026
- https://github.com/XjSv/Cooked/security/advisories/GHSA-9vfv-c966-jwrv
Get alerted when CVE-2024-37308 or the next vulnerability affects your stack