What’s Vulnerable › Vulnerabilities
CVE-2024-37313: Nextcloud server allows the by-pass the second factor
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-287
Description
Nextcloud server is a self hosted personal cloud system. Under some circumstance it was possible to bypass the second factor of 2FA after successfully providing the user credentials. It is recommended that the Nextcloud Server is upgraded to 26.0.13, 27.1.8 or 28.0.4 and Nextcloud Enterprise Server is upgraded to 21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13, 25.0.13.8, 26.0.13, 27.1.8 or 28.0.4.
Affected products
- Nextcloud Server: from 21.0.0 before 21.0.9.17; from 22.0.0 before 22.2.10.22; from 23.0.0 before 23.0.12.17; from 24.0.0 before 24.0.12.13; from 25.0.0 before 25.0.13.8; from 26.0.0 before 26.0.13 — fixed in 21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13, 25.0.13.8, 26.0.13
How to fix
Upgrade to a fixed version: Nextcloud Server 21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-9v72-9xv5-3p7c
- https://github.com/nextcloud/server/pull/44276
- https://hackerone.com/reports/2419776
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-9v72-9xv5-3p7c
- https://github.com/nextcloud/server/pull/44276
- https://hackerone.com/reports/2419776
Get alerted when CVE-2024-37313 or the next vulnerability affects your stack