What’s Vulnerable › Vulnerabilities
CVE-2024-37315: Nextcloud Server's read-only users can restore old versions
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-284
Description
Nextcloud Server is a self hosted personal cloud system. An attacker with read-only access to a file is able to restore older versions of a document when the files_versions app is enabled. It is recommended that the Nextcloud Server is upgraded to 26.0.12, 27.1.7 or 28.0.3 and that the Nextcloud Enterprise Server is upgraded to 23.0.12.16, 24.0.12.12, 25.0.13.6, 26.0.12, 27.1.7 or 28.0.3.
Affected products
- Nextcloud Server: from 23.0.0 through 23.0.12; from 24.0.0 through 24.0.12; from 25.0.0 before 25.0.13; from 26.0.0 before 26.0.12; from 27.0.0 before 27.1.7; from 28.0.0 before 28.0.3 — fixed in 25.0.13, 26.0.12, 27.1.7, 28.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 25.0.13, 26.0.12, 27.1.7, 28.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5mq8-738w-5942
- https://github.com/nextcloud/server/pull/43727
- https://hackerone.com/reports/1356508
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5mq8-738w-5942
- https://github.com/nextcloud/server/pull/43727
- https://hackerone.com/reports/1356508
Get alerted when CVE-2024-37315 or the next vulnerability affects your stack