What’s Vulnerable › Vulnerabilities
CVE-2024-37358: Apache James: denial of service through the use of IMAP literals
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-06 · updated 2026-06-17
- Weakness: CWE-770
Description
Similarly to CVE-2024-34055, Apache James is vulnerable to denial of service through the abuse of IMAP literals from both authenticated and unauthenticated users, which could be used to cause unbounded memory allocation and very long computations Version 3.7.6 and 3.8.2 restrict such illegitimate use of IMAP literals.
Affected products
- Apache James Server: before 3.7.6; from 3.8.0 before 3.8.2 — fixed in 3.7.6, 3.8.2
How to fix
Upgrade to a fixed version: Apache James Server 3.7.6, 3.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37358 or the next vulnerability affects your stack