What’s Vulnerable › Vulnerabilities
CVE-2024-37389: Apache NiFi: Improper Neutralization of Input in Parameter Context Description
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Affected products
- Apache Software Foundation Apache NiFi: from 1.10.0 before 1.27.0; 2.0.0-milestone1, 2.0.0-milestone1-rc1, 2.0.0-milestone1-rc2, 2.0.0-milestone1-rc3, 2.0.0-milestone1-rc4, 2.0.0-milestone1-rc5 (+8) — fixed in 1.27.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 1.27.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yso9fr0wtff53nk046h1o83hdyb1lrxh
- http://www.openwall.com/lists/oss-security/2024/07/08/1
- https://lists.apache.org/thread/yso9fr0wtff53nk046h1o83hdyb1lrxh
Get alerted when CVE-2024-37389 or the next vulnerability affects your stack