What’s Vulnerable › Vulnerabilities
CVE-2024-37392
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting (XSS) vulnerability has been identified in SMSEagle software version < 6.0. The vulnerability arises because the application did not properly sanitize user input in the SMS messages in the inbox. This could allow an attacker to inject malicious JavaScript code into an SMS message, which gets executed when the SMS is viewed and specially interacted in web-GUI.
Affected products
- SMSEagle: before 6.0 — fixed in 6.0
How to fix
Upgrade to a fixed version: SMSEagle 6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37392 or the next vulnerability affects your stack