What’s Vulnerable › Vulnerabilities
CVE-2024-3740: cym1102 nginxWebUI reload exec deserialization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-13 · updated 2026-06-17
- Weakness: CWE-502
Description
A vulnerability, which was classified as critical, has been found in cym1102 nginxWebUI up to 3.9.9. This issue affects the function exec of the file /adminPage/conf/reload. The manipulation of the argument nginxExe leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-260579.
Affected products
- cym1102 nginxWebUI: before 4.2.4 — fixed in 4.2.4
How to fix
Upgrade to a fixed version: cym1102 nginxWebUI 4.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/cym1102/nginxWebUI/files/14818455/nginxwebui.rce.3.9.9.pdf
- https://github.com/cym1102/nginxWebUI/issues/138
- https://vuldb.com/?ctiid.260579
- https://vuldb.com/?id.260579
- https://vuldb.com/?submit.311216
- https://github.com/cym1102/nginxWebUI/files/14818455/nginxwebui.rce.3.9.9.pdf
- https://github.com/cym1102/nginxWebUI/issues/138
- https://vuldb.com/?ctiid.260579
- https://vuldb.com/?id.260579
- https://vuldb.com/?submit.311216
Get alerted when CVE-2024-3740 or the next vulnerability affects your stack