What’s Vulnerable › Vulnerabilities
CVE-2024-37401
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read in IPsec of Ivanti Connect Secure before version 22.7R2.1 allows a remote unauthenticated attacker to cause a denial of service.
Affected products
- Ivanti Connect Secure (Pulse Secure): before 22.7; 22.7, 22.7-r1, 22.7-r1.1, 22.7-r1.2, 22.7-r1.3, 22.7-r1.4 (+5) — fixed in 22.7
- Ivanti Policy Secure: before 22.7; 22.7, 22.7-r1, 22.7-r1.1 — fixed in 22.7
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 22.7; Ivanti Policy Secure 22.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37401 or the next vulnerability affects your stack