What’s Vulnerable › Vulnerabilities
CVE-2024-37422: WordPress Progress Planner plugin <= 0.9.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Progress Planner Progress Planner progress-planner.This issue affects Progress Planner: from n/a through <= 0.9.2.
Affected products
- Progress Planner: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: Progress Planner 0.9.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/progress-planner/vulnerability/wordpress-progress-planner-plugin-0-9-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/progress-planner/wordpress-progress-planner-plugin-0-9-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37422 or the next vulnerability affects your stack