What’s Vulnerable › Vulnerabilities
CVE-2024-37437: WordPress Elementor Website Builder plugin <= 3.22.1 - Arbitrary SVG File Download vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor.This issue affects Elementor Website Builder: from n/a through <= 3.22.1.
Affected products
- Elementor Website Builder: before 3.22.2 — fixed in 3.22.2
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.22.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/elementor/vulnerability/wordpress-elementor-website-builder-more-than-just-a-page-builder-plugin-3-22-1-arbitrary-file-download-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/elementor/wordpress-elementor-website-builder-more-than-just-a-page-builder-plugin-3-22-1-arbitrary-file-download-vulnerability?_s_id=cve
Get alerted when CVE-2024-37437 or the next vulnerability affects your stack