What’s Vulnerable › Vulnerabilities
CVE-2024-37445: WordPress HTML5 Audio Player plugin <= 2.2.23 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in bPlugins Html5 Audio Player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through 2.2.23.
Affected products
- bPlugins Html5 Audio Player: before 2.2.24 — fixed in 2.2.24
How to fix
Upgrade to a fixed version: bPlugins Html5 Audio Player 2.2.24. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/html5-audio-player/wordpress-html5-audio-player-plugin-2-2-23-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/html5-audio-player/wordpress-html5-audio-player-plugin-2-2-23-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37445 or the next vulnerability affects your stack