What’s Vulnerable › Vulnerabilities
CVE-2024-37457: WordPress Ultimate Blocks – WordPress Blocks Plugin plugin <= 3.1.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks – Gutenberg Blocks Plugin allows Stored XSS.This issue affects Ultimate Blocks – Gutenberg Blocks Plugin: from n/a through 3.1.9.
Affected products
- ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor 3.2.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ultimate-blocks/wordpress-ultimate-blocks-wordpress-blocks-plugin-plugin-3-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ultimate-blocks/wordpress-ultimate-blocks-wordpress-blocks-plugin-plugin-3-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37457 or the next vulnerability affects your stack