What’s Vulnerable › Vulnerabilities
CVE-2024-37459: WordPress PayPlus Payment Gateway plugin <= 6.6.8 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in PayPlus LTD PayPlus Payment Gateway allows Reflected XSS.This issue affects PayPlus Payment Gateway: from n/a through 6.6.8.
Affected products
- PayPlus Payment Gateway: before 6.6.9 — fixed in 6.6.9
How to fix
Upgrade to a fixed version: PayPlus Payment Gateway 6.6.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/payplus-payment-gateway/wordpress-payplus-payment-gateway-plugin-6-6-8-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/payplus-payment-gateway/wordpress-payplus-payment-gateway-plugin-6-6-8-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37459 or the next vulnerability affects your stack