What’s Vulnerable › Vulnerabilities
CVE-2024-37460: WordPress SuperSaaS – online appointment scheduling plugin <= 2.1.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in SuperSaaS SuperSaaS – online appointment scheduling allows Stored XSS.This issue affects SuperSaaS – online appointment scheduling: from n/a through 2.1.9.
Affected products
- SuperSaaS – online appointment scheduling: before 2.1.10 — fixed in 2.1.10
How to fix
Upgrade to a fixed version: SuperSaaS – online appointment scheduling 2.1.10. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/supersaas-appointment-scheduling/wordpress-supersaas-online-appointment-scheduling-plugin-2-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/supersaas-appointment-scheduling/wordpress-supersaas-online-appointment-scheduling-plugin-2-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37460 or the next vulnerability affects your stack