What’s Vulnerable › Vulnerabilities
CVE-2024-37476: WordPress Newspack Campaigns plugin <= 2.31.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in Automattic Newspack Campaigns allows Stored XSS.This issue affects Newspack Campaigns: from n/a through 2.31.1.
Affected products
- Automattic Newspack Campaigns: before 2.31.2 — fixed in 2.31.2
How to fix
Upgrade to a fixed version: Automattic Newspack Campaigns 2.31.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/newspack-popups/wordpress-newspack-campaigns-plugin-2-31-1-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/newspack-popups/wordpress-newspack-campaigns-plugin-2-31-1-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37476 or the next vulnerability affects your stack