What’s Vulnerable › Vulnerabilities
CVE-2024-37489: WordPress Ocean Extra plugin <= 2.2.9 - Authenticated Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in OceanWP Ocean Extra allows Stored XSS.This issue affects Ocean Extra: from n/a through 2.2.9.
Affected products
- oceanwp Ocean Extra: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: oceanwp Ocean Extra 2.3.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ocean-extra/wordpress-ocean-extra-plugin-2-2-9-authenticated-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ocean-extra/wordpress-ocean-extra-plugin-2-2-9-authenticated-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37489 or the next vulnerability affects your stack