What’s Vulnerable › Vulnerabilities
CVE-2024-37500: WordPress Beaver Builder plugin <= 2.8.2.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Beaver Builder Team Beaver Builder allows Stored XSS.This issue affects Beaver Builder: from n/a through 2.8.2.2.
Affected products
- beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder: before 2.8.3 — fixed in 2.8.3
How to fix
Upgrade to a fixed version: beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder 2.8.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/beaver-builder-lite-version/wordpress-beaver-builder-plugin-2-8-2-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/beaver-builder-lite-version/wordpress-beaver-builder-plugin-2-8-2-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37500 or the next vulnerability affects your stack