What’s Vulnerable › Vulnerabilities
CVE-2024-37502: WordPress Social Login plugin <= 2.6.3 - PHP Object Injection vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in wpweb WooCommerce Social Login woo-social-login.This issue affects WooCommerce Social Login: from n/a through <= 2.6.3.
Affected products
- WPWeb WooCommerce - Social Login: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: WPWeb WooCommerce - Social Login 2.7.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/woo-social-login/vulnerability/wordpress-social-login-wordpress-woocommerce-plugin-plugin-2-6-3-php-object-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woo-social-login/wordpress-social-login-wordpress-woocommerce-plugin-plugin-2-6-3-php-object-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-37502 or the next vulnerability affects your stack