What’s Vulnerable › Vulnerabilities
CVE-2024-37509: WordPress MakeCommerce for WooCommerce plugin <= 3.5.1 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Maksekeskus AS MakeCommerce for WooCommerce allows Reflected XSS.This issue affects MakeCommerce for WooCommerce: from n/a through 3.5.1.
Affected products
- Maksekeskus AS MakeCommerce for WooCommerce: before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: Maksekeskus AS MakeCommerce for WooCommerce 3.5.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/makecommerce/wordpress-makecommerce-for-woocommerce-plugin-3-5-1-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/makecommerce/wordpress-makecommerce-for-woocommerce-plugin-3-5-1-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37509 or the next vulnerability affects your stack