What’s Vulnerable › Vulnerabilities
CVE-2024-37519: WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin <= 2.1.27 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Leap13 Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through <= 2.1.27.
Affected products
- Leap13 Premium Blocks – Gutenberg Blocks for WordPress: before 2.1.28 — fixed in 2.1.28
How to fix
Upgrade to a fixed version: Leap13 Premium Blocks – Gutenberg Blocks for WordPress 2.1.28. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/premium-blocks-for-gutenberg/vulnerability/wordpress-premium-blocks-gutenberg-blocks-for-wordpress-plugin-2-1-27-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/premium-blocks-for-gutenberg/wordpress-premium-blocks-gutenberg-blocks-for-wordpress-plugin-2-1-27-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37519 or the next vulnerability affects your stack