What’s Vulnerable › Vulnerabilities
CVE-2024-37527: IBM OpenPages with Watson cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM OpenPages with Watson 8.3 and 9.0 is vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM OpenPages with Watson: from 8.3 before 8.3.0.3; from 9.0 before 9.0.0.4 — fixed in 8.3.0.3, 9.0.0.4
How to fix
Upgrade to a fixed version: IBM OpenPages with Watson 8.3.0.3, 9.0.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-37527 or the next vulnerability affects your stack