What’s Vulnerable › Vulnerabilities
CVE-2024-3753: Hostel < 1.1.5.3 - Reflected XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Hostel WordPress plugin before 1.1.5.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Bob Hostel: before 1.1.5.3 — fixed in 1.1.5.3
How to fix
Upgrade to a fixed version: Bob Hostel 1.1.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e140e109-4176-4b26-bf63-198262a31409/
- https://wpscan.com/vulnerability/e140e109-4176-4b26-bf63-198262a31409/
Get alerted when CVE-2024-3753 or the next vulnerability affects your stack