What’s Vulnerable › Vulnerabilities
CVE-2024-37536: WordPress Easy Custom Code (LESS/CSS/JS) Plugin <= 1.0.8 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Web357 Easy Custom Code (LESS/CSS/JS) – Live editing allows Stored XSS.This issue affects Easy Custom Code (LESS/CSS/JS) – Live editing: from n/a through 1.0.8.
Affected products
- Web357 Easy Custom Code (LESS/CSS/JS) – Live editing: before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: Web357 Easy Custom Code (LESS/CSS/JS) – Live editing 1.0.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/easy-custom-code/wordpress-easy-custom-code-less-css-js-plugin-1-0-8-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/easy-custom-code/wordpress-easy-custom-code-less-css-js-plugin-1-0-8-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37536 or the next vulnerability affects your stack