What’s Vulnerable › Vulnerabilities
CVE-2024-3761: Missing Authorization on Delete Datasets in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-20 · updated 2026-06-17
- Weakness: CWE-862
Description
In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.
Affected products
- lunary-ai/lunary: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776
- https://huntr.com/bounties/e95fb0a0-e54a-4da8-a33d-ba858d0cec55
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776
- https://huntr.com/bounties/e95fb0a0-e54a-4da8-a33d-ba858d0cec55
Get alerted when CVE-2024-3761 or the next vulnerability affects your stack