What’s Vulnerable › Vulnerabilities
CVE-2024-3764: Tuya SDK MQTT Packet denial of service
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-14 · updated 2026-06-17
- Weakness: CWE-404
Description
** DISPUTED ** A vulnerability classified as problematic has been found in Tuya SDK up to 5.0.x. Affected is an unknown function of the component MQTT Packet Handler. The manipulation leads to denial of service. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. Upgrading to version 5.1.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-260604. NOTE: The vendor explains that a malicious actor would have to crack TLS first or use a legitimate login to initiate the attack.
Affected products
- Tuya SDK: 5.0
References
- https://github.com/kzLiu2017/Tuya_Cam_CVE_Doc/blob/main/CVE%20Doc.pdf
- https://vuldb.com/?ctiid.260604
- https://vuldb.com/?id.260604
- https://vuldb.com/?submit.311860
- https://github.com/kzLiu2017/Tuya_Cam_CVE_Doc/blob/main/CVE%20Doc.pdf
- https://vuldb.com/?ctiid.260604
- https://vuldb.com/?id.260604
- https://vuldb.com/?submit.311860
Get alerted when CVE-2024-3764 or the next vulnerability affects your stack