What’s Vulnerable › Vulnerabilities
CVE-2024-37884: Nextcloud Server's users can delete old versions of read-only shared files
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-284
Description
Nextcloud Server is a self hosted personal cloud system. A malicious user was able to send delete requests for old versions of files they only got shared with read permissions. It is recommended that the Nextcloud Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3 and that the Nextcloud Enterprise Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3.
Affected products
- Nextcloud Server: from 25.0.0 before 25.0.13.7; from 26.0.0 before 26.0.13; from 27.0.0 before 27.1.8; from 28.0.0 before 28.0.4 — fixed in 25.0.13.7, 26.0.13, 27.1.8, 28.0.4
How to fix
Upgrade to a fixed version: Nextcloud Server 25.0.13.7, 26.0.13, 27.1.8, 28.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwgx-f37p-xh8c
- https://github.com/nextcloud/server/pull/43727
- https://hackerone.com/reports/2290680
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwgx-f37p-xh8c
- https://github.com/nextcloud/server/pull/43727
- https://hackerone.com/reports/2290680
Get alerted when CVE-2024-37884 or the next vulnerability affects your stack