What’s Vulnerable › Vulnerabilities
CVE-2024-37886: Nextcloud user_oidc's ID4me does not validate signature or expiration
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-347
Description
user_oidc app is an OpenID Connect user backend for Nextcloud. An attacker could potentially trick the app into accepting a request that is not signed by the correct server. It is recommended that the Nextcloud user_oidc app is upgraded to 1.3.5, 2.0.0, 3.0.0, 4.0.0 or 5.0.0.
Affected products
- nextcloud User Oidc: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: nextcloud User Oidc 1.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vw5h-29xf-g55g
- https://github.com/nextcloud/user_oidc/pull/715
- https://hackerone.com/reports/1878391
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vw5h-29xf-g55g
- https://github.com/nextcloud/user_oidc/pull/715
- https://hackerone.com/reports/1878391
Get alerted when CVE-2024-37886 or the next vulnerability affects your stack