What’s Vulnerable › Vulnerabilities
CVE-2024-37888: The Open Link CKEditor plugin has a cross-site scripting (XSS) vulnerability in open link functionality
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Open Link is a CKEditor plugin, extending context menu with a possibility to open link in a new tab. The vulnerability allowed to execute JavaScript code by abusing link href attribute. It affects all users using the Open Link plugin at version < **1.0.5**.
Affected products
- mlewand ckeditor-plugin-openlink: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: mlewand ckeditor-plugin-openlink 1.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/mlewand/ckeditor-plugin-openlink/security/advisories/GHSA-rhxf-gvmh-hrxm
- https://github.com/mlewand/ckeditor-plugin-openlink/security/advisories/GHSA-rhxf-gvmh-hrxm
Get alerted when CVE-2024-37888 or the next vulnerability affects your stack